26 May 2008

Intel 945 on Hardy, Part 2

I posted a while back about issues with Intel 945 and Compiz on Hardy. I put up a script for the 2.6.24-16 kernel to recompile with support for it. For all you running 2.6.24-17, the kernel you need has been posted to a PPA. Get the kernel and the kernel headers from the PPA.


3 comments:

M. le Prof d'Anglais said...

Before I install, I had a question. When I open the deb file, I see the message:

You likely do not want to install this package directly. Instead, install the linux-generic meta-package, which will ensure that upgrades work correctly, and that supporting packages are also installed.

As a non-techie I wonder whether to go ahead. Compiz already works fine, although my favourite game doesn't. Can you just reassure me it's OK. Will I still get kernel upgrades?

Mackenzie said...

linux-generic depends on whatever the current kernel version is.

You don't need this kernel if Compiz works though. This kernel is for people with a specific version of the i945 chip. If yours works with Compiz already, you don't have that version.

The game probably doesn't work well with Intel because Intel is integrated graphics with shared memory. Discrete graphics (ATI or Nvidia with dedicated video memory) may be necessary to handle the visual effects the game uses.

Yes, you'll still get kernel updates after installing this kernel.

Zugley said...

Thanks, for this. I love youre blog.
Greetings from sweden.

M